Installation sur free.fr

enthalpie

Joined: 2007-09-13
Posts: 14
Posted: Mon, 2007-09-24 18:39

ca y est !!(presque) il a fallu mettre dans une page ce code

les albums photos<div class="g2image_normal"><wpg2id>34</wpg2id></div>

qui se met automatiquement si l'on clique au bon endroit sur la fenêtre de wpg2 !!!

reste que maintenant les albums s'affichent mais pas les photos et les sous albums mais je vais trouver !!

 
enthalpie

Joined: 2007-09-13
Posts: 14
Posted: Sun, 2007-09-23 18:32

Et ça y est !!

si on désactive l'Url re-writing alors on visualise bien les albums
et sous albums

YOUPI

et merci

 
Barbrousse

Joined: 2007-05-22
Posts: 168
Posted: Mon, 2007-09-24 08:25

Je ne sais pas où vous avez trouvé l'info pour le <div class="g2image_normal"><wpg2id>34</wpg2id></div> parce que je trouve ça drôlement mal documenté !

Je suis heureux que vous ayez trouvé et que vous nous ayez indiqué comment.

Barbrousse.

 
enthalpie

Joined: 2007-09-13
Posts: 14
Posted: Mon, 2007-09-24 18:39

vraiment par hasard et je suis d'accord ce n'est pas vraiment bien renseigné, du moins je n'ai pas trouvé cela dans le faq ou le how-two

cordialement

 
toutoucouleur

Joined: 2007-03-13
Posts: 24
Posted: Sun, 2007-09-30 06:34

Bonjour Barbrousse
en juin j'avais installé gallery 2.2.2 avec les extensions de free tous fonctionnait impeccable
mais je viens d'installer gallery 2.2.3 avec les extenstions de free mais j'ai cette erreur lorsque je veux
acceder a la page d'album general pour mettre le titre et les mots cles

Fatal error: Smarty error: [in gallery:modules/core/templates/ItemEditItem.tpl line 112]: syntax error: unrecognized tag 'html_select_date' (Smarty_Compiler.class.php, line 583) in /mnt/xxx/free.fr/f/2/monlogin/gallery2/lib/smarty/Smarty.class.php on line 1095

sinon la galerie fonctionne quelque
soit le theme utilisé
sinon comment je peux retrouver gallery 2.2.2 dans les downlad j'ai essayé mais je trouve que gallery 2.2.3
merci d'avance

 
shivaya

Joined: 2006-12-22
Posts: 132
Posted: Sun, 2007-09-30 12:15

Essaye ceci:
Tu vas dans la partie administration/maintenance
et tu fais "exécuter maintenant" sur "Effacer le cache des templates" puis "Effacer le cache de la base de données"

 
toutoucouleur

Joined: 2007-03-13
Posts: 24
Posted: Sat, 2007-10-06 05:13

Bonjour
j'ai installer gallery 2.2.3 sur free.fr avec les extensions de Barbrousse
faut il supprimer le repertoire installation pour des raisons de securité
merci d'avance

 
Barbrousse

Joined: 2007-05-22
Posts: 168
Posted: Sat, 2007-10-06 14:24

D'après cette page : http://codex.gallery2.org/Gallery2:Security#Do_I_need_to_delete_the_install.2F_and_upgrade.2F_folders_after_the_installation.3F , vous pouvez le faire, et même supprimer le répertoire "upgrade", ce n'est pas obligatoire, et ça ne nuit pas au fonctionnement de Gallery de le faire ou de ne pas le faire.

Ce que je conseille fortement pour mieux sécuriser votre page perso sur Free, c'est d'utiliser un mot de passe différent pour le FTP, la base de données SQL et votre login administrateur de Gallery (et encore un différent pour vos autres scripts PHP de weblog, forums, etc.). C'est faisable depuis quelques mois sur votre console de gestion. Comme ça, si un mot de passe est compromis, ça ne compromet pas l'ensemble votre page perso.

Barbrousse.

 
scpsc

Joined: 2007-10-08
Posts: 2
Posted: Wed, 2007-10-10 14:10

Bonjour,

Tout d'abord, merci pour votre adaptation de gallery2 version free :)

j'ai un soucis que je n'arrive pas à résoudre : il arrive que tout à coup, je ne puisse plus accéder à gallery2 par le lien que j'ai mis dans mon site joomla. Le message d'erreur est le suivant :

Quote:
Not Found
The requested URL /gallery2/i:0; was not found on this server.

Apache/ProXad [May 15 2007 17:32:33] Server at monsite.free.fr Port 80

Je ne comprends pas bien ce qui fait apparaître cette erreur mais elle n'est pour l'instant apparue que lorsque je me connecte avec un compte Registered et que je bidouille un album (je supprime une image, j'en ajoute une). Je ne sais pas du tout si c'est lié à ces manips, je ne comprends pas.

mon site tourne avec joomla 1.0.13 et gallery2 bridge 2.0.14.

Merci d'avance :)

edit : lorsque ça marche, l'url est bien http://monsite.free.fr/index.php?option=com_gallery2&Itemid=43 et non pas galler2/i:0;

 
shivaya

Joined: 2006-12-22
Posts: 132
Posted: Wed, 2007-10-10 13:39

C'est plus un problème lié au module bridge de joomla, donc voir plutôt avec le créateur du module.

 
scpsc

Joined: 2007-10-08
Posts: 2
Posted: Wed, 2007-10-10 14:12
shivaya wrote:
C'est plus un problème lié au module bridge de joomla, donc voir plutôt avec le créateur du module.

J'ai fait une fausse manip qui a décalé mon post précédent, désolé : /
Merci pour ta réponse, je vais voir avec eux en espérant trouver une solution.

 
shivaya

Joined: 2006-12-22
Posts: 132
Posted: Wed, 2007-10-10 14:37

De mémoire ce composant a toujours eu des problèmes, tiens nous au courant quand même ;)

 
remkodevos

Joined: 2007-10-12
Posts: 1
Posted: Fri, 2007-10-12 15:10

Is there an option that your hack is avaleble in English? My provider also has his safe mode on. Perhaps I can try you hack at my server.

kind regards Remko de Vos

 
tim_12

Joined: 2007-10-13
Posts: 1
Posted: Sat, 2007-10-13 17:13

Bonjour, merci Barbrouss pour toutes ces infos,
chez moi ça a bien marché sur free, mais il y a des bugs pour les thèmes slider et hybrid que je n'arrive pas à faire fonctionner correctement (thèmes utilisant javascript à outrance, et utilisation de la fonction getUrlGenerator()). Est-ce que quelqu'un a réussi faire fonctionner le thème hybrid avec un gallery integré à PHPNuke ou autre? comment?
Les symptomes sont les suivants:
-IE7 signale une erreur sur les pages chargées concernant une variable indéfinie : data_count
La définition de data_count est réalisée dans le fichier templates/header.tpl qui est bien référencé et appelé par theme.inc. Alors pourquoi ce signalement d'erreur?
On a : var data_count = data_iw.length, data_name = '{$theme.item.id}'
avec arg2="itemId=`$theme.item.id`" dans templates/detail.tpl
- Clic sur lien Cacher les détails et Afficher les liens : retour sur la page d'acceuil
- L'affichage des albums et de leurs miniatures fonctionnent bien, par contre, les liens des miniatures renvoient sur la page d'acceuil après une apparition furtive de la fenêtre javascript d'affichage de la photo "en grand". Sur Firefox, les liens sont bons mais une fois l'image chargé, on retombe sur la page d'acceuil (racine de mon site).
Mon installation de gallery est integré à phpNuke et c'est peut-être une source de problème supplémentaire.
Je pense que ce thème n'a pas été écrit pour générer et gérer des liens de type "modules.php?name=gallery2&g2_itemId=21".
Je vais chercher de mon coté et je ne manquerai pas de faire avancer ce sujet mais je suis encore novice en php.
Si vous avez des infos à ce sujet pour me mettre sur la piste, je suis preneur.
Merci

 
toutoucouleur

Joined: 2007-03-13
Posts: 24
Posted: Mon, 2007-10-15 04:20

bonjour
j'ai un petit soucis avec l'installation des composants dcraw,ffmpeg,imagemagick et netpbm
quel chemin je dois mettre pour les configurer dans ma partie administration
merci d'avance

 
Barbrousse

Joined: 2007-05-22
Posts: 168
Posted: Mon, 2007-10-15 07:17
toutoucouleur wrote:
j'ai un petit soucis avec l'installation des composants dcraw,ffmpeg,imagemagick et netpbm

C'est logique que vous ayez un petit soucis, on ne peut installer aucun de ces modules chez Free parce qu'ils nécessitent d'ajouter ou d'accéder à des exécutables sur le serveur, ce qui n'est pas possible chez Free. Si vous "uploadez" un fichier exécutable, il ne sera pas vu comme exécutable après l'upload, donc il n'y a rien que vous puissiez y faire.

Barbrousse.

 
Barbrousse

Joined: 2007-05-22
Posts: 168
Posted: Mon, 2007-10-15 07:33
remkodevos wrote:
Is there an option that your hack is avaleble in English? My provider also has his safe mode on. Perhaps I can try you hack at my server.

The hack proposed here may work for any provider with "safe mode on". As far as I can remember now, the hack is not language dependant, so you should take the last gallery version, unzip it and overwrite the files with those from the last gallery2.2-safe-mode-on-free.fr-mod-patch-200x-xx-xx.zip hack (see the first post), upload all files and begin installation.

During installation, try to keep the data folder as proposed (i.e. "...whatever/mylogin/gallery2/g2data"), if an installation step fails, don't hesitate to try again the current step by clicking its number in the left column.

After the installation, you should download "...whatever/mylogin/gallery2/config.php" and edit it to change the line $gallery->setConfig('data.gallery.base', '...whatever/mylogin/gallery2/g2data'); to $gallery->setConfig('data.gallery.base', $_SERVER['DOCUMENT_ROOT'] . '/gallery2/g2data/'); (if your provider server uses Apache) and upload the file.

For any future updates, always reupload the files from the last hack after the update files and before beginning the update process.

Barbrousse.

 
lol.2.dol

Joined: 2007-10-16
Posts: 13
Posted: Tue, 2007-10-16 00:55

Bonjour, Bonjour,
Voilà je cherche à installer une gallerie qui supporte le streaming Video et qui soit installable sur Free. Avant j'étais avec ZenPhoto(et le Hack ZEnVideos), mais petit problème, je ne pouvais pas afficher des photos d'une taille supérieur à 2 ou 2,5Mo(à cause d'une limitation de chez Free au niveau du PHP). J'ai donc cherché une nouvelle galerie, et je me suis tournée vers Gallery.
Première question: Est-ce qu'il y a déjà eu des problèmes avec des photos relativement lourdes?
Deuxième question: D'après ce que j'ai pu lire sur les 6 pages de ce merveilleux topic(merci barbrousse et les autres!!), on en peut pas installer ffmpeg, donc ça veut dire pas de support de la video? ou seulement pour les thumbnails? et le FLV fonctionne à part non?
Troisème question: J'étais habitué avec ZenPhoto, à uploader directement mes dossier de photos via un client FTP, et ZenPhoto se débrouillait tout seul pour trouver les photos, et en fait les miniatures. D'après ce que j'ai lu, avec Galery c'est pas aussi simple. Il faut créer le dossier avant, indiquer à Gallery qu'il faut qu'il cherche des photos... J'ai lu le mauvaise article ou ça se passe vraiement comme ça?

En tout cas, merci pour le boulot accompli, je vais tenter l'installation demain!

@+

 
shivaya

Joined: 2006-12-22
Posts: 132
Posted: Tue, 2007-10-16 02:48

1) plus aucun problème, ça été résolu grâce au patch de Barbrousse !
2) les vidéos fonctionnent très bien, ffmpeg permet de créer la vignette vidéo, ffmpeg ne peut être installé sur free.fr, donc pas de vignette automatique, mais on peut toujours mettre une vignette, en le faisant manuellement.
3) c'est assez simple, tu verras c'est prévu pour. (il peut même chercher les images dans une page web)

 
Barbrousse

Joined: 2007-05-22
Posts: 168
Posted: Tue, 2007-10-16 07:18

Petites précisions

1) L'upload par PHP présente évidemment la même limitation : 2 Mo maximum, donc il va falloir passer par le FTP pour déposer des fichiers plus gros. Le download a été effectivement arrangé par le patch et ne présente plus de limitation, en tout cas pour les images. Honnêtement, j'avais sur mon blog des vidéos en FLV que je lisais avec un plugin flash, mais j'ai fini par mettre tout ça sur dailymotion, parce que les gens chez Orange se plaignaient que ça mettait trop de temps à charger pour les regarder. De l'aveu même des gens de chez Free, ils brident les vidéos en streaming.

3) Il y a une foultitude d'options pour déposer des fichiers : http://codex.gallery2.org/Gallery2:How_to_Add_Items et en particulier c'est peut-être ça qui vous intéresse : http://codex.gallery2.org/Gallery2:How_to_Add_Items#How_to_Add_Items_from_the_Local_Server_.28or_with_FTP.29

Barbrousse.

 
jeclic

Joined: 2007-09-14
Posts: 48
Posted: Tue, 2007-10-16 08:01

Bonjour Barbrousse,
je réagis sur les vidéos, votre remarque est tout à fait juste, sur free ça rame vachement.
je n'ai pas encore étudié l'importation de vidéos dans Gallery, ça ne serait tarder, mais je me posais juste la question à lire votre post, si on pouvait faire appeler sur les pages de Gallery, des vidéos hébergées à l'extérieur.
Cela impliquerait de donner le lien à la création de la vignette par exemple... Faisable ou pas ?

 
Barbrousse

Joined: 2007-05-22
Posts: 168
Posted: Tue, 2007-10-16 09:04

Quand vous ajoutez un élément, il vous est déjà proposé d'ajouter un lien vers un élément extérieur, sur lequel vous pouvez mettre une vignette personnalisée, je regarderai s'il y a moyen d'embarquer une vidéo Youtube ou Dailymotion.

Barbrousse.

 
Barbrousse

Joined: 2007-05-22
Posts: 168
Posted: Tue, 2007-10-16 09:18

Regardez le plugin (faites une recherche du mot clé "zip") sur cette page : http://gallery.menalto.com/node/65656?page=1

Ca fonctionne pour Youtube, pour les liens directs vers des vidéos ".flv", mais pas pour Dailymotion, mais ce n'est probablement pas très difficile à adapter.

Barbrousse.

 
jeclic

Joined: 2007-09-14
Posts: 48
Posted: Tue, 2007-10-16 09:50

Ben, m'a l'air pas mal ce plugin !
Il répondrait bien à ma question, je vais le tester dans le jours à venir.
C'est pas mal comme solution du coup !!
Affaire à suivre...

 
lol.2.dol

Joined: 2007-10-16
Posts: 13
Posted: Tue, 2007-10-16 10:38

Parfit!
Merci pour toute ses réponses, Ô Combien utiles!
Je me lance dans l'installation!
Merci encore! J'aime pas cette expression, mais "vous gérez"!

 
Floleriderdu13

Joined: 2007-10-16
Posts: 4
Posted: Tue, 2007-10-16 10:47

Salut tout le monde,

Je vois qu'il y'a des français sur ce topic donc j'en profite pour poser ma question, desolé si ce n'est pas le bonne endroit !!

Est ce qu'il y'a une traduction française pour Gallery?

J'ai cherché dans ce topic mais j'ai rien trouvé:
http://gallery.menalto.com/node/8369

Est ce qu'il y'a une fonction ajouter dans Panier pour que je puisses vendre mes photos?

Et dernière question, est ce qu'on peut ajouter en masse les photos?

Merci, désolé pour le HS

@+

 
Barbrousse

Joined: 2007-05-22
Posts: 168
Posted: Tue, 2007-10-16 11:26

Oui, Gallery supporte de base plusieurs langues, dont le français, il y a bien un panier pour faire développer ses photos (chez Digibug, PhotoWorks, FotoWire/Silverwire, Fotokasten, Shutterfly) dans les plugins standard et pour l'ajout de masse de photos, il y a un programme "Gallery Remote" et un applet de téléchargement intégré en Java qui sont fort pratiques pour ajouter pleins de photos à la fois.

Si vous voulez vendre vos propres photos, il y a bien des plugins supplémentaires pour cela (regardez http://codex.gallery2.org/Gallery2:User_Contributions#Modules et en particulier le module qui utilise PayPal, il y a aussi Google Checkout, Checkout-xx et Checkout2CO à voir si ça fonctionne en France.).

Mais vous devez être conscient de ceci : l'accès aux photos en haute résolution, même protégées par des permissions ou par mot de passe peuvent quand même être accessibles : un utilisateur peut très bien faire un lien vers une de vos photos, une fois qu'il aura eu accès au moins une fois à la photo en haute résolution et donc qu'il connaitra son chemin "http://blabla/photo.jpg". Cette limitation est due au patch car il ne cache plus le chemin réel des photos et les rend accessibles directement pour des raisons de performance sur les pages persos de Free. Vous pouvez rétablir la fonctionnalité originale en rétablissant les fichiers "gallery2/modules/core/classes/GalleryUrlGenerator.class", "gallery2/modules/rewrite/classes/RewriteUrlGenerator.class", "gallery2/modules/core/DownloadItem.inc", "gallery2/modules/watermark/DownloadItem.inc" originaux après avoir appliqué le patch (détails ici : http://codex.gallery2.org/Gallery2:Patch_for_french_ISP_free.fr), puis en créant un fichier ".htaccess" contenant "deny from all" dans votre répertoire "gallery2/g2data", mais vous rendrez le visionnage de votre galerie plus lent.

Barbrousse.

 
Floleriderdu13

Joined: 2007-10-16
Posts: 4
Posted: Tue, 2007-10-16 11:59

Merci pour tes renseigments

 
shivaya

Joined: 2006-12-22
Posts: 132
Posted: Tue, 2007-10-16 12:50
Barbrousse wrote:
Honnêtement, j'avais sur mon blog des vidéos en FLV que je lisais avec un plugin flash, mais j'ai fini par mettre tout ça sur dailymotion, parce que les gens chez Orange se plaignaient que ça mettait trop de temps à charger pour les regarder. De l'aveu même des gens de chez Free, ils brident les vidéos en streaming.

Barbrousse.

Je dois avoir une bonne centaines de vidéos en FLV, ça marche très bien, alors certes c'est lent la journée mais pas plus que de télécharger une grosse image, par contre j'ai mit un cache de 20 secondes sur le player.

Ils brident tout un tas de choses chez free.fr (dont des ports)

 
Barbrousse

Joined: 2007-05-22
Posts: 168
Posted: Tue, 2007-10-16 13:07

Avez-vous testé du PC de quelqu'un qui est chez Orange ? Parce que moi, j'avais mis 30 secondes de buffer, et ça passait, mais de chez Orange, c'était abominable, alors que Dailymotion passait correctement.

Barbrousse.

 
shivaya

Joined: 2006-12-22
Posts: 132
Posted: Tue, 2007-10-16 14:06

Non pas testé.

Les déboires et les coups bas entre ces deux FAI ont toujours été, d'ailleurs il faut être un peu (voir beaucoup) mazo pour rester chez kakadoo alias Orange !

edit:
d'ailleurs ils en payent les frais, je cite :
Dans un communiqué du 15 octobre 2007, le Conseil de la concurrence annonce la sanction de l'opérateur historique à hauteur de 45 millions d'euros pour "avoir entravé le développement des fournisseurs d'accès concurrents de sa filiale Wanadoo"

 
morpheuss

Joined: 2007-10-16
Posts: 4
Posted: Wed, 2007-10-17 10:14

si vous avez ce type de message qui apparait juste au moment de l'installation, c'est que vous n'avez pas créer de dossier "sessions" à la racine de votre site WEB attention pas dans votre dossier gallery mais à la racine du site, recharger votre page et tout et OK

ou monsite est le nom de votre site

Quote:
Warning: session_start() [function.session-start]: open(/mnt/152/sdc/0/b/monsite/sessions/sess_d84ad3e4c6dbac86149fb4b40ff7bb7b, O_RDWR) failed: No such file or directory (2) in /mnt/152/sdc/0/b/monsite/gallery2/lib/support/GallerySetupUtilities.class on line 348

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /mnt/152/sdc/0/b/monsite/gallery2/lib/support/GallerySetupUtilities.class:348) in /mnt/152/sdc/0/b/monsite/gallery2/lib/support/GallerySetupUtilities.class on line 348

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /mnt/152/sdc/0/b/qu'amarineraient/gallery2/lib/support/GallerySetupUtilities.class:348) in /mnt/152/sdc/0/b/monsite/gallery2/lib/support/GallerySetupUtilities.class on line 348

Warning: session_start() [function.session-start]: open(/mnt/152/sdc/0/b/monsite/sessions/sess_9ac157c629b0da438e27f8a013336375, O_RDWR) failed: No such file or directory (2) in /mnt/152/sdc/0/b/monsite/gallery2/lib/support/GallerySetupUtilities.class on line 75

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /mnt/152/sdc/0/b/monsite/gallery2/lib/support/GallerySetupUtilities.class:348) in /mnt/152/sdc/0/b/monsite/gallery2/lib/support/GallerySetupUtilities.class on line 75

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /mnt/152/sdc/0/b/monsite/gallery2/lib/support/GallerySetupUtilities.class:348) in /mnt/152/sdc/0/b/monsite/gallery2/lib/support/GallerySetupUtilities.class on line 75

attention chez free, ils ont mysql MySQL 5.0.45 et dans l'install il faut donc choisir Mysql (versions postérieurs à V3.23.34a) laisser localhost, root, il faut juste indiquer son mot de passe de base qui normalement celui du compte mail

barberousse merci de la précision pour mysql j'ai corrigé mon erreur, ce message c'est pour aider ceux qui ont un peu de mal comme moi

 
Barbrousse

Joined: 2007-05-22
Posts: 168
Posted: Tue, 2007-10-16 14:24
morpheuss wrote:
attention chez free, ils ont mysql 2.6.3-pl1 et dans l'install il faut donc choisir Mysql (versions antérieures à V3.23.34a) laisser localhost, root, il faut juste indiquer son mot de passe de base qui normalement celui du compte mail

Attention, grosse confusion, ils ont phpMyAdmin version 2.6.3-pl1 mais MySQL 5.0.45 donc il faut choisir MySQL versions postérieures à V3.23.34a.

Barbrousse.

 
pelrol

Joined: 2007-07-26
Posts: 5
Posted: Wed, 2007-10-17 09:41

Hello Barbrousse !

Ma gallerie tournait depuis qqe temps en 2.1, et la semaine dernière, je suis passé en 2.2.3 en suivant tes instructions !
Tout s'est bien passé, mis à part un petit problème : lorsque je rajoute des images dans des albums, ceux ci deviennent super instables. En passant en mode débug, j'ai le résultat suivant (http://pelrol.free.fr/gallery2/main.php?g2_itemId=336&g2_navId=xbfcead7d):

file_exists(/mnt/137/sdc/6/b/pelrol/gallery2/g2data/cache/module/_all/0/0/GalleryStorage_describeEntity.inc)
<hr />

(mysqlt): SELECT g2_DerivativeImage.g_width, g2_DerivativeImage.g_height, g2_Derivative.g_derivativeSourceId, g2_Derivative.g_derivativeOperations, g2_Derivative.g_derivativeOrder, g2_Derivative.g_derivativeSize, g2_Derivative.g_derivativeType, g2_Derivative.g_mimeType, g2_Derivative.g_postFilterOperations, g2_Derivative.g_isBroken, g2_ChildEntity.g_parentId, g2_Entity.g_id, g2_Entity.g_creationTimestamp, g2_Entity.g_isLinkable, g2_Entity.g_linkId, g2_Entity.g_modificationTimestamp, g2_Entity.g_serialNumber, g2_Entity.g_entityType, g2_Entity.g_onLoadHandlers FROM g2_DerivativeImage, g2_Derivative, g2_ChildEntity, g2_Entity WHERE g2_DerivativeImage.g_id IN (3695) AND g2_Derivative.g_id=g2_DerivativeImage.g_id AND g2_ChildEntity.g_id=g2_DerivativeImage.g_id AND g2_Entity.g_id=g2_DerivativeImage.g_id &nbsp; 
<hr />

file_exists(/mnt/137/sdc/6/b/pelrol/gallery2/g2data/cache/derivative/3/6)
is_dir(/mnt/137/sdc/6/b/pelrol/gallery2/g2data/cache/derivative/3/6)
file_exists(/mnt/137/sdc/6/b/pelrol/gallery2/g2data/cache/entity/3/7/3712.inc)
file_exists(/mnt/137/sdc/6/b/pelrol/gallery2/g2data/cache/entity/3/7/3711.inc)
file_exists(/mnt/137/sdc/6/b/pelrol/gallery2/modules/gd/classes/GdToolkit.class)
file_exists(/mnt/137/sdc/6/b/pelrol/gallery2/g2data/cache/entity/3/6/3690.inc)
<hr />
(mysqlt): 
	    SELECT
	      g2_TkOperatnMimeTypeMap.g_toolkitId,
	      g2_TkOperatnMap.g_outputMimeType
	    FROM
	      g2_TkOperatnMap,
	      g2_TkOperatnMimeTypeMap
	    WHERE
	      g2_TkOperatnMap.g_name =
		g2_TkOperatnMimeTypeMap.g_operationName
	      AND
	      g2_TkOperatnMimeTypeMap.g_mimeType = 'image/jpeg'
	      AND
	      g2_TkOperatnMap.g_name = 'thumbnail'
	    ORDER BY
	      g2_TkOperatnMimeTypeMap.g_priority ASC
	     &nbsp; 
<hr />

GdToolkit::performOperation(image/jpeg,thumbnail,/mnt/137/sdc/6/b/pelrol/gallery2/g2data/albums/2007/4_2007/2007_09_08/IMG_3059.JPG,/mnt/137/sdc/6/b/pelrol/gallery2/g2data/cache/derivative/3/6/3695.dat,150)
Lock id 29410 was left hanging!

Est ce que cela signifie que GD ne renvoie jamais la miniature ?
une autre idée ?

Merci bcp,
pelrol.

 
shivaya

Joined: 2006-12-22
Posts: 132
Posted: Wed, 2007-10-17 10:54
morpheuss wrote:
si vous avez ce type de message qui apparait juste au moment de l'installation, c'est que vous n'avez pas créer de dossier "sessions" à la racine de votre site WEB attention pas dans votre dossier gallery mais à la racine du site, recharger votre page et tout et OK

ou monsite est le nom de votre site

Quote:
Warning: session_start() [function.session-start]: open(/mnt/152/sdc/0/b/monsite/sessions/sess_d84ad3e4c6dbac86149fb4b40ff7bb7b, O_RDWR) failed: No such file or directory (2) in /mnt/152/sdc/0/b/monsite/gallery2/lib/support/GallerySetupUtilities.class on line 348

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /mnt/152/sdc/0/b/monsite/gallery2/lib/support/GallerySetupUtilities.class:348) in /mnt/152/sdc/0/b/monsite/gallery2/lib/support/GallerySetupUtilities.class on line 348

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /mnt/152/sdc/0/b/qu'amarineraient/gallery2/lib/support/GallerySetupUtilities.class:348) in /mnt/152/sdc/0/b/monsite/gallery2/lib/support/GallerySetupUtilities.class on line 348

Warning: session_start() [function.session-start]: open(/mnt/152/sdc/0/b/monsite/sessions/sess_9ac157c629b0da438e27f8a013336375, O_RDWR) failed: No such file or directory (2) in /mnt/152/sdc/0/b/monsite/gallery2/lib/support/GallerySetupUtilities.class on line 75

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /mnt/152/sdc/0/b/monsite/gallery2/lib/support/GallerySetupUtilities.class:348) in /mnt/152/sdc/0/b/monsite/gallery2/lib/support/GallerySetupUtilities.class on line 75

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /mnt/152/sdc/0/b/monsite/gallery2/lib/support/GallerySetupUtilities.class:348) in /mnt/152/sdc/0/b/monsite/gallery2/lib/support/GallerySetupUtilities.class on line 75

attention chez free, ils ont mysql MySQL 5.0.45 et dans l'install il faut donc choisir Mysql (versions postérieurs à V3.23.34a) laisser localhost, root, il faut juste indiquer son mot de passe de base qui normalement celui du compte mail

barberousse merci de la précision pour mysql j'ai corrigé mon erreur, ce message c'est pour aider ceux qui ont un peu de mal comme moi

Si tu avais lu le premier post de ce topic, tu n'aurais pas eu cette erreur !
Mais encore fallait-il prendre la peine de lire...

 
morpheuss

Joined: 2007-10-16
Posts: 4
Posted: Wed, 2007-10-17 11:27

merci pour ta remarque shivaya, agréable!!!!!!!!!!!!
j'apporte mon aide comme tout le monde ici, et si des personnes se retrouve avec cette erreur et qu'il font une recherche dans le forum sur le texte de l'erreur au moins ils trouveront directement la réponse !! mais bon, mon expérience est surement inutile!!!! en fait moi je la partage mon expérience, je poste pas en quote pour rien dire

concernant le paramétrage de la base je n'ai rien vu dans le premier post alors excuse moi d'apporter ma pierre à l'édifice

à bon entendeur

 
shivaya

Joined: 2006-12-22
Posts: 132
Posted: Wed, 2007-10-17 11:59
morpheuss wrote:
merci pour ta remarque shivaya, agréable!!!!!!!!!!!!
j'apporte mon aide comme tout le monde ici, et si des personnes se retrouve avec cette erreur et qu'il font une recherche dans le forum sur le texte de l'erreur au moins ils trouveront directement la réponse !! mais bon, mon expérience est surement inutile!!!! en fait moi je la partage mon expérience, je poste pas en quote pour rien dire

concernant le paramétrage de la base je n'ai rien vu dans le premier post alors excuse moi d'apporter ma pierre à l'édifice

à bon entendeur

Moi quand je ne connais pas quelque chose, je n'affirme pas des choses que je ne connais pas, et viens pas me parler de partage à moi stp.

Si tu avais simplement posé la question on t'aurait répondu, simplement.

 
Barbrousse

Joined: 2007-05-22
Posts: 168
Posted: Wed, 2007-10-17 12:22

Suite à la remarque de Morpheuss, j'ai indiqué dans le post initial les versions de MySQL et PostgreSQL proposées par Free, parce que ce n'est effectivement pas forcément évident à trouver. Par contre, il est bien indiqué qu'il faut créer le répertoire "sessions" à la racine de la page personnelle (j'ai insisté dans le post initial), mais une piqûre de rappel ne fait pas de mal.

Et ne vous fachez pas, je ne voudrais pas que le topic parte en flammes ;-)

Barbrousse.

 
morpheuss

Joined: 2007-10-16
Posts: 4
Posted: Wed, 2007-10-17 12:30

je n'avais aucune question à poser mais juste faire partager mon expérience de ce que j'avais vécu lors de mon install donc j'ai passé des infos me semblant utiles

si ta conception du partage c'est agressé les gens quand ils s'exprime ou essaye d'émettre une opinion et bien bravo

et rassure toi après ce message je ne sais pas si quelqu'un oseras te poser une question parce que quand on t'en poses pas t'en voit chier les gens alors quand on t'en poses j'aimerai voir ça!!

maintenant l'erreur est humaine j'avais le droit de me tromper sur la version de la base, barberousse me l'a indiqué j'ai changé mon post et si tu avais été un brin intelligent tu n'aurais pas écris ton post, mais on peut pas en demander trop a quelqu'un qui dit

Quote:
viens pas me parler de partage à moi stp.

désolé barberousse mais je ne pensais pas que mon post à la base d'aide en arrive la et désolé pour les autres membres mais je ne supporte pas les agressifs et donneurs de leçon du style "t'aurai du lire". On est la pour l'aide mais la prochaine fois je ne ferais pas passer l'info, ça m'apprendra "à partager"
STOP pour moi

 
shivaya

Joined: 2006-12-22
Posts: 132
Posted: Wed, 2007-10-17 12:47

La c'est toi qui devient agressif et vulgaire, je n'ai envoyé personne "chier" comme tu le dis, reste cool man, et apprends l'humilité...

 
morpheuss

Joined: 2007-10-16
Posts: 4
Posted: Wed, 2007-10-17 12:54

MDR humilité me voila :

shivaya wrote:
et viens pas me parler de partage à moi stp

 
shivaya

Joined: 2006-12-22
Posts: 132
Posted: Wed, 2007-10-17 13:01
morpheuss wrote:
MDR humilité me voila :
shivaya wrote:
et viens pas me parler de partage à moi stp

Et arrête de juger les gens sans les connaître.

 
lol.2.dol

Joined: 2007-10-16
Posts: 13
Posted: Thu, 2007-10-18 17:26

Bonjour,
J'ai réussi à installer Gallery sur mon FTP Free grâce à votre aide!
Mais j'ai un problème, mes photos ne s'affichent pas...
Je les ai uploadé par la métode du client FTP, je peux les selectionner, mais après je ne les vois pas dans la galerie.
Je me demande si c'est pas un problème de droit sur le répertoire dans lequel j'envoie mes photos.

Merci

 
Barbrousse

Joined: 2007-05-22
Posts: 168
Posted: Thu, 2007-10-18 21:04

Pour vous aider, il faudrait que vous nous décriviez exactement comment vous avez franchi les étapes pour envoyer vos photos par FTP, en donnant les chemins, quitte à remplacer votre login free par un login bidon si vous voulez garder votre galerie privée.

Ce qui est sûr, c'est que ça ne peut pas être un problème de droit sur les fichiers ou les répertoires, vous ne pouvez pas les changer chez Free, donc vous ne pouvez pas vous tromper.

Barbrousse.

 
lol.2.dol

Joined: 2007-10-16
Posts: 13
Posted: Thu, 2007-10-18 21:41

Ok
Bon alors la méthode que j'ai suivi:
J'ai créé un repertoire Photos à la racine de mon FTP, dedans j'ai mis des photos!
J'ai installé et configuré le module Ajout d'élements avec l'adresse /mnt/163/sda/5/6/XXXXX/Photos

Ensuite, je suis allez dans ma galerie, j'ai cliquer sur Ajouter des éléments, puis cliquer sur l'onglet: Depuis le serveur local, j'ai choisi mon repertoire, quelques photos et quand j'ai cliquer sur Suivant(ou Ajouter), j'ai été redirigé vers une page blanche...(pas bon signe je pense)
Ensuite dans la galerie, c'est assez bizarre, parfois les albums apparaissent, parfois non.. En tout cas les photos ne sont pas visible(case vide)!

Les photos ont bien été copiés, mais c'est tout...
Ah si, dans le haut de la fenêtre, il y a une ligne qui indique le nombre d'éléments dans la galerie, et il me met bien le nombre de photos que j'ai uploadé!

Merci

 
shivaya

Joined: 2006-12-22
Posts: 132
Posted: Fri, 2007-10-19 00:49

Regarde ici déjà
Vois tu les .htaccess sur ton FTP ?

 
Barbrousse

Joined: 2007-05-22
Posts: 168
Posted: Fri, 2007-10-19 06:24

Je plussoie Shivaya.

Je ne vois aucune erreur dans la façon dont vous vous y prenez.

Avez-vous installé la bibliothèque GD dans les modules ?

Pouvez-vous me fournir l'adresse de votre page perso par messagerie privée (et à Shivaya aussi, il peut avoir des idées également) ?

Barbrousse.

 
Barbrousse

Joined: 2007-05-22
Posts: 168
Posted: Fri, 2007-10-19 13:42
lol.2.dol wrote:
Les photos ont bien été copiés, mais c'est tout...
Ah si, dans le haut de la fenêtre, il y a une ligne qui indique le nombre d'éléments dans la galerie, et il me met bien le nombre de photos que j'ai uploadé!

Si vous ne voyez le ou les albums que quand vous êtes connecté comme administrateur, éditez les persmissions sur le ou les albums et ajoutez la permission "[noyau] Voir toutes les versions" pour le groupe "Tous" par exemple.

Si ce n'est pas ça, pourriez-vous me donner temporairement un accès administrateur à votre galerie, par messagerie privée ?

Barbrousse.

 
shivaya

Joined: 2006-12-22
Posts: 132
Posted: Fri, 2007-10-19 15:29

En effet ça semble être plutôt un problème de permissions (il y a 3 éléments mais non visible en guest), lol.2.dol pour que les invités (c'est à dire les non membres) puissent voir les albums OU les photos il faut le définir au préalable, et "Tous" correspond aux invités.

Ce qui serait plutôt étrange (anormal) c'est quand étant administrateur vous ne puissiez pas voir les 3 éléments...

 
lol.2.dol

Joined: 2007-10-16
Posts: 13
Posted: Fri, 2007-10-19 16:14

En effet, même en étant Admin, je ne vois pas les fichiers!
Je vous envoie par MP les identifiants administrateurs!
Merci!