dynamic album questions

cascoly

Joined: 2008-02-20
Posts: 21
Posted: Tue, 2008-03-04 07:44

i have images of knights in several albums, organized by country. i'd like to have a knights album

i know i can do that with a new album, then add replicas of all the images, but instead could i list a link to a dynamic keyword album for "knight"? how? i realize someone could do this by clicking on that keyword, but i want to list it [and other topics] for users to see at the top of the hierarchy

my site: http://pix-now.com/main.php

steve

------------------------------

http://cascoly.silentsale.hop.clickbank.net
Put eBay on AUTOPILOT!
Earn a serious income with a part-time effort

 
floridave
floridave's picture

Joined: 2003-12-22
Posts: 27300
Posted: Tue, 2008-03-04 18:58

use the link item module ( http://codex.gallery2.org/Gallery2:Modules:linkitem )and add the url to the dynamic album you your choice. Add a custom thumb for that item as well if you have the thumbnail module installed.

Dave
_____________________________________________
Blog & G2 || floridave - Gallery Team

 
cascoly

Joined: 2008-02-20
Posts: 21
Posted: Tue, 2008-03-04 21:39

thanks -- i set up a keyword album, and now that part works, but i get no images for ANY dynamic album - whether keyword, random, etc [ clicking on keywords DID worj earlier] -- instead i get a gallery screen with sidebar but no images

the end of the source page is:


<div class="block-albumselect-AlbumTree gbBlock">
<div class="dtree">
<p>
<a href="javascript: albumTree.openAll()"
onclick="this.blur()">Expand</a>
|
<a href="javascript: albumTree.closeAll()"
onclick="this.blur()">Collapse</a>
</p>
<script type="text/javascript">
// <![CDATA[
function albumSelect_goToNode(nodeId) {
document.location = new String('

so looks like something's gotten mixed up -- how to proceed from here? do i need to reinstall certain modules?

i added a header & footer to theme.tpl in local and all was working fine - still is, unless i try keywords or dynamic. removing that and clearing template cache doesnt change anything

steve
my site: http://pix-now.com/main.php

Last Run Details:

Gallery version = 2.2.4 core 1.2.0.6
PHP version = 4.4.7 cgi
Webserver = Apache/1.3.33 (Unix)
Database = mysqlt 5.0.51-log, lock.system=flock
Toolkits = ArchiveUpload, Exif, Getid3, LinkItemToolkit, NetPBM, Thumbnail, Gd, SquareThumb
Acceleration = full/86400, full/86400
Operating system = Linux infong 2.4 #1 SMP Thu Jan 13 08:59:31 CET 2005 i686 unknown
Default theme = matrix
gettext = enabled
Locale = en_US
Browser = Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30)
Rows in GalleryAccessMap table = 27
Rows in GalleryAccessSubscriberMap table = 302
Rows in GalleryUser table = 4
Rows in GalleryItem table = 297
Rows in GalleryAlbumItem table = 29
Rows in GalleryCacheMap table = 595

 
floridave
floridave's picture

Joined: 2003-12-22
Posts: 27300
Posted: Tue, 2008-03-04 21:49

Yah, I see http://pix-now.com/main.php?g2_view=keyalbum.KeywordAlbum&g2_keyword=canada but no content. Seems that the album select module has a issue with short urls. perhpas. Diable the album select moudule for the dynamic album and it should work.
Start a new thread about that module causing issues in the trouble shooting forums. It might be the stats module as well or the permalinks causing issues.
see: http://gallery.menalto.com/node/69163#comment-268173

Dave

_____________________________________________
Blog & G2 || floridave - Gallery Team

 
cascoly

Joined: 2008-02-20
Posts: 21
Posted: Wed, 2008-03-05 00:06
Quote:
Diable the album select moudule for the dynamic album and it should work.

??? how do i do that?

i'm on siteadmin / dyn album settings but dont see anything about album select

====-
after reading the comments you suggested, i went to plugins and deactivated url rewrite , and now the dynamic - random images works, and a keyword search on 'mountain' also works

btw, i also ran the statistics - disk - recalc in the last day or so, like the other person did

steve

 
floridave
floridave's picture

Joined: 2003-12-22
Posts: 27300
Posted: Wed, 2008-03-05 03:44

So I guess statistics module is the culprit.
I will see if he/she can have a look.

Dave
_____________________________________________
Blog & G2 || floridave - Gallery Team

 
cascoly

Joined: 2008-02-20
Posts: 21
Posted: Wed, 2008-03-05 20:36

ok, would it still be useful to start a new thread as you suggested?

 
floridave
floridave's picture

Joined: 2003-12-22
Posts: 27300
Posted: Thu, 2008-03-06 01:47

I sent a PM to the author of the stats module but have not heard back.

Dave
_____________________________________________
Blog & G2 || floridave - Gallery Team