Looking for FFMPEG binary for Mac OS X

cuwet

Joined: 2003-08-17
Posts: 7
Posted: Thu, 2005-08-11 16:10

Hi I'm looking for FFMPEG binary for Mac OS X...
does anybody know where to find....

thanks
cuwet

 
valiant

Joined: 2003-01-04
Posts: 32509
Posted: Thu, 2005-08-11 16:52

nope, if we knew of some ffmpeg binaries for platform x, there would be a link to it in our codex.gallery2.org.

 
TvE
TvE's picture

Joined: 2004-07-03
Posts: 76
Posted: Thu, 2005-08-11 21:36
 
cuwet

Joined: 2003-08-17
Posts: 7
Posted: Fri, 2005-08-12 03:42

Thanks... exactly what i've been looking for...

 
tcashen

Joined: 2005-08-12
Posts: 1
Posted: Fri, 2005-08-12 16:31

I tried using DarwinPorts to install ffmpeg for Mac OS X, but it didn't work. Then, I tried just downloading the source and installing it myself. Still didn't work. (I believe the compile error was about needing 64-bit support, and I'm running a G4.) So, I just downloaded the ffmpegX program which includes the ffmpeg binary.

Here are instructions:

1. download ffmpegX
2. open .dmg package
3. control-click on ffmpegX and select "Show Package Contents"
4. find Contents/Resources/ffmpeg
5. copy ffmpeg to somewhere like /usr/local/bin
6. set the path to the ffmpeg binary in Gallery (e.g., /usr/local/bin/ffmpeg)

Seems to be working fine.

Ty

 
cuwet

Joined: 2003-08-17
Posts: 7
Posted: Thu, 2005-08-18 16:54

Thanks tcashen,

You are a star... I too could not get the darwin port version to install.... but the ffmpegX binary did it... yeah... everything is now installed....

 
rocoso

Joined: 2006-08-05
Posts: 5
Posted: Sat, 2006-08-05 19:24

Thanks! That worked.

 
freakQNC
freakQNC's picture

Joined: 2006-09-14
Posts: 8
Posted: Thu, 2006-09-14 15:15

I found the info above after a long day of digging the net. Since it solved my problem I believe is worth to give it more redundancy and allow search engines to find faster. This way to find a solution should result a bit easier for all those gallery2 users who are experiencing problems with the ffmpeg module configuration. So if you landed to this in less than 1/2 day your googleing has paid off before mine did ;)

I will summarize below what is the ONLY solution to make Gallery2 validate ffmpeg binary so that you will never get any of those infamous "no decode delegate for this image format" errors!!!

How to add ffmpeg to Gallery2 running on Mac OS X (by tcashen):

[b]1. Download ffmpegX
2. Open .dmg package
3. Control-click on ffmpegX and select "Show Package Contents"
4. Find Contents/Resources/ffmpeg
5. Copy ffmpeg to somewhere like /usr/local/bin
6. set the path to the ffmpeg binary in Gallery2 (e.g., /usr/local/bin/ffmpeg)
7. Test the configuration which should report "Passed" and the list of supported MIME file types that the module will support.
8. Save the configuration for the module
9. Activate the module

You are done with FFMPEG and GALLERY2! Have fun!
[b]

 
valiant

Joined: 2003-01-04
Posts: 32509
Posted: Thu, 2006-09-14 15:47

freakQNC

thanks for summarizing the steps.
http://codex.gallery2.org/index.php/Gallery2:Modules:ffmpeg is a much better place for this information though.

please add it either there or create a new codex wiki page and link it on that page.

thanks!

 
freakQNC
freakQNC's picture

Joined: 2006-09-14
Posts: 8
Posted: Thu, 2006-09-14 17:44

Absolutely agree! Thanks for bringing it to my attention valiant... plus will increase the redundancy ;D

I added the instruction in the wiki section "Gallery2:Modules:ffmpeg" http://codex.gallery2.org/index.php/Gallery2:Modules:ffmpeg#Usage and also linked to it form the Wiki Gallery2: Installation Requirements http://codex.gallery2.org/index.php/Gallery2:Installation_Requirements#ffmpeg

Hopefully those info will help smooth the process of getting their installation going for all new Mac+Gallery2 users. :)

Peace.

 
valiant

Joined: 2003-01-04
Posts: 32509
Posted: Thu, 2006-09-14 20:28

thanks. tiny correction: for links within the wiki (from one wiki page to another one), use [[pagename|link text]] instead of [url link text]. i've fixed it already.

 
freakQNC
freakQNC's picture

Joined: 2006-09-14
Posts: 8
Posted: Thu, 2006-09-14 21:33

Oops, sorry and thanks for the fix. I have to remember how to do that, that's a new thing learnt today :)
...I haven't used wiki all that much, can you tell? :P