Note to users getting the unable to create thumbnail error

Yog

Joined: 2004-11-03
Posts: 5
Posted: Wed, 2004-11-03 03:59

Recent versions of ImageMagick apparently no longer support (dunno if it's intentional or not) the +profile '*' option to remove profiles from an image. For a quick fix, edit your util.php file and change this line in the compress_image() function:
. ($keepProfiles ? ' ' : ' +profile \'*\' ')
to this:
. ($keepProfiles ? ' ' : ' -strip ')

 
doggyk

Joined: 2004-11-04
Posts: 1
Posted: Thu, 2004-11-04 06:17

FANTASTIC!

I spent hours trying to fix this problem, saw your post and problem solved in a few minutes!

I was using the latest non-Beta Gallery, Solaris 9 x86 and the latest Magick package from Blastwave.org.

Many thanks,

Dave

 
signe
signe's picture

Joined: 2003-07-27
Posts: 2322
Posted: Thu, 2004-11-04 22:27

Yog, which "most recent version" is that?

It's still supported in

Version: ImageMagick 6.0.6 10/03/04 Q16 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2004 ImageMagick Studio LLC

 
skander

Joined: 2004-11-08
Posts: 2
Posted: Mon, 2004-11-08 16:34

ImageMagick-6.1.3-2.tar.bz2 broke it for me.

 
dstutz

Joined: 2005-01-09
Posts: 1
Posted: Sun, 2005-01-09 06:45

Thanks for the fix. I was experiencing the same prob with 6.1.3.4. Very quick and easy :)

 
Daylen

Joined: 2005-08-08
Posts: 5
Posted: Sat, 2005-08-13 19:11

i cant find that code

 
signe
signe's picture

Joined: 2003-07-27
Posts: 2322
Posted: Sat, 2005-08-13 20:26

It shouldn't be necessary if you're using Gallery 1.5.0 or above.

 
mombos

Joined: 2005-01-04
Posts: 49
Posted: Tue, 2005-08-16 22:06

i changed the line in util.php but am still getting the same error message, i am using 1.4.1pl4

does anyone have any ideas on how i may be able to get it working?

 
Jordan_01002

Joined: 2005-02-14
Posts: 1535
Posted: Wed, 2005-08-17 10:11

For one, you might try upgrading to 1.5.

 
mombos

Joined: 2005-01-04
Posts: 49
Posted: Wed, 2005-08-17 21:01

possibly, but the site is built around that version and runs fine on my own server just having this problem on another host.

Cheers

 
mombos

Joined: 2005-01-04
Posts: 49
Posted: Wed, 2005-08-17 21:24

just installed 1.5.1RC2 and get exactly the same error, i made a new topic with the error in because of the lengh of it,

nevermind i installed netpbm and its all working now