Gallery 3.0 RC2 Feedback

bharat
bharat's picture

Joined: 2002-05-21
Posts: 7993
Posted: Tue, 2010-07-06 02:56

OMG STAND BACK! The second and hopefully last release candidate is out! Sorry it took so long.. we've been a little busy and we wanted to polish this sucker up something special. I hope you like it. Feel free to rant and rave below, we look forward to reading your feedback.
---
Problems? Check gallery3/var/logs
bugs/feature req's | upgrade to the latest code | use git

 
paka

Joined: 2006-02-14
Posts: 3
Posted: Tue, 2010-07-06 19:56

paka
http://wahoo.no-ip.org/gallery2

comming from gallery 2.3.1

In gallery2 I was able to symlink to my original photos and leave them in their original
directory structure w/o duplicating them and filling my /srv file partition.

Is there the ability to use symlinks to the original photos when adding photos to the gallery3
database or do I need to increase the size of my /srv partition?

btw, I really like the looks and feel of the gallery3 rc2, but am unhappy about the amount of
additional disk space required if there is no linking capability.

tks,

 
floridave
floridave's picture

Joined: 2003-12-22
Posts: 27300
Posted: Tue, 2010-07-06 20:00

paka, There is no symbolic link capablity yet in G3.

Dave

_____________________________________________
Blog & G2 || floridave - Gallery Team

 
paka

Joined: 2006-02-14
Posts: 3
Posted: Tue, 2010-07-06 20:10

Then I guess I will have to wait for it :^(
I do not have the space available (and do not want to allocate
that much space) in the /srv partition for my *complete* album
structure.

tks,

paka
http://wahoo.no-ip.org

 
paka

Joined: 2006-02-14
Posts: 3
Posted: Tue, 2010-07-06 21:06

what about a link to /srv/www/htdocs/gallery3/var
on another partition/disk?

paka
http://wahoo.no-ip.org

 
Dimtar

Joined: 2010-06-29
Posts: 3
Posted: Wed, 2010-07-07 01:07

Is anyone aware of the php settings etc. for the server? Just went to upload a 20mb image and it couldn't process.

 
floridave
floridave's picture

Joined: 2003-12-22
Posts: 27300
Posted: Wed, 2010-07-07 02:50

FAQ: Why can't I upload big files (over a megabyte or two)?
But even with very high upload limits you might still have issues with 20Mb files. Use the server add method.

Dave
_____________________________________________
Blog & G2 || floridave - Gallery Team

 
rob
rob's picture

Joined: 2002-08-15
Posts: 22
Posted: Wed, 2010-07-07 05:22

I unziped Gallery 3.0 RC2 (from rc1) which upgraded Organize to v2 that required enabling the included REST API Module v3 but when I try to use it, the air app loads but displays a "Remote server error, please contact your gallery administrator"...

gallery3/modules/organize/lib/Gallery3WebClient.swf?1278384426 seem to ask for /crossdomain.xml which I added as

<?xml version="1.0"?>
<!DOCTYPE cross-domain-policy SYSTEM "http://www.macromedia.com/xml/dtds/cross-domain-policy.dtd">
<cross-domain-policy>
<site-control permitted-cross-domain-policies="all"/>
<allow-access-from domain="*" secure="false" />
<allow-access-from domain="*.cooliris.com" secure="false" />
</cross-domain-policy>

but I don't see any other hints in apache22 error logs or gallery3/var/logs, so I'm kinda confused... do you have any ideas where to go from here?

 
krak
krak's picture

Joined: 2009-06-23
Posts: 5
Posted: Wed, 2010-07-07 12:57

Thanks for G3RC2. I had an old issue with large files; most pictures failed* to upload (2M limit). I fixed it by uploading the file php.ini** to root of the gallery installation.
Maybe this is something for error handling / documentation.

* received error messages
'228.JPG - Unable to proces this file'
'229.JPG - Invalid upload'

** php.ini
post_max_size = 50M
upload_max_filesize = 50M

 
krak
krak's picture

Joined: 2009-06-23
Posts: 5
Posted: Wed, 2010-07-07 13:11

Organize album (from album or menu) gives me a window with the message: 'Error #2030'.

 
floridave
floridave's picture

Joined: 2003-12-22
Posts: 27300
Posted: Wed, 2010-07-07 14:04

use the from local server method to add larger items.

Dave

_____________________________________________
Blog & G2 || floridave - Gallery Team

 
shecter
shecter's picture

Joined: 2006-12-30
Posts: 130
Posted: Wed, 2010-07-07 15:47

Just installed G3R2 -- love it and the new add photo, folder and delete buttons in organization. Still waiting for ability to use gallery remote, and an embedding method for Wordpress. But Gallery3R2 is great. Nice Work!

-Marc

 
edbeeny

Joined: 2009-11-26
Posts: 14
Posted: Wed, 2010-07-07 21:24

Rob,

Im getting the same error, have you had any luck in fixing?
Thanks

 
scaturan
scaturan's picture

Joined: 2004-09-12
Posts: 1153
Posted: Thu, 2010-07-08 05:58

bug i was able to reproduce was originally reported by floridave - next time, i will look at track for existing tickets then report back.

sorry!

 
bharat
bharat's picture

Joined: 2002-05-21
Posts: 7993
Posted: Thu, 2010-07-08 01:27

Good work, @scaturan! You found a bug -- filed as https://sourceforge.net/apps/trac/gallery/ticket/1186
---
Problems? Check gallery3/var/logs
bugs/feature req's | upgrade to the latest code | use git

 
micrographics

Joined: 2010-02-18
Posts: 79
Posted: Thu, 2010-07-08 05:56

Hi Bharat

I downloaded RC2 and copied to my server. After that when I ran Upgrader, It shows list of modules needed to upgrade but when I click on UPGRADE ALL, it does nothing and it shows again same thing.

 
bharat
bharat's picture

Joined: 2002-05-21
Posts: 7993
Posted: Thu, 2010-07-08 13:43

@micrographics: is there anything in your gallery3 log files? Check gallery3/var/logs. What modules need upgrading? Can you share a screenshot with us?
---
Problems? Check gallery3/var/logs
bugs/feature req's | upgrade to the latest code | use git

 
micrographics

Joined: 2010-02-18
Posts: 79
Posted: Thu, 2010-07-08 14:04

Bharat

Find attached screenshot.

1.jpg - before clicking on Upgrade All
2.jpg - After clicking on Upgrade All with progress indicator
3.jpg - After progress indicator completes process

Also attached log file.

I manually copied PhotoWidget 1.1 from the Forum but it still showing same thing.

 
bharat
bharat's picture

Joined: 2002-05-21
Posts: 7993
Posted: Thu, 2010-07-08 15:08

Ah, ok. Two things.

1) That page doesn't look very good in IE :-)
https://sourceforge.net/apps/trac/gallery/ticket/1188

2) 3rd party modules that have buggy upgrade code can cause the upgrader to think that there's work left to do, but there's really nothing it can do.
https://sourceforge.net/apps/trac/gallery/ticket/1189

For now, just ignore PhotoWidget and keep going. Please report this back to the PhotoWidget author -- they have a bug in their upgrade code.

---
Problems? Check gallery3/var/logs
bugs/feature req's | upgrade to the latest code | use git

 
floridave
floridave's picture

Joined: 2003-12-22
Posts: 27300
Posted: Thu, 2010-07-08 15:45
Quote:
the PhotoWidget author -- they have a bug in their upgrade code.

Will work on that when I get home tonight.

Dave
_____________________________________________
Blog & G2 || floridave - Gallery Team

 
edbeeny

Joined: 2009-11-26
Posts: 14
Posted: Thu, 2010-07-08 22:16

I eventually changed hosts away from 1and1 and now the gallery organizer works well.

 
ferguson731

Joined: 2010-07-09
Posts: 8
Posted: Fri, 2010-07-09 01:45

Longtime gallery user. Great work by the developers. Thank your for your efforts.

I'm sorry to say that in 3.0-rc2 I still can't logout, exactly as described in bug #1039 (apparently pasting in the url triggers the spam filter).

Forbidden

You don't have permission to access /gallery/index.php/logout on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache mod_fcgid/2.3.5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at ... Port 80

This on a hostgator shared server. I have not enabled fastcgi, nor does the cpanel handler page show that it is enabled server-wide. phpinfo attached.

I installed rc2 by copying the dist to the server, then moving my var/ directory from my rc1 install.

I don't recall having a problem logging out in rc1 (but who knows?).

George

 
zzpy20
zzpy20's picture

Joined: 2007-09-27
Posts: 2
Posted: Fri, 2010-07-09 07:11

Great work!

Just to report that the user/group management seems to be tricky and not quite well designed for permission purposes.

For example, there is a default group(can't be deleted) called "Everyone", which contains every user in database. this makes it confusing for the application to grant right permission for certain groups. If I wanna hide an album from users(public) except the "admin", can't even manage that. Because the "admin" is alway in group "Everyone". If I set 'Everyone" can't see the album, the admin can't see either. Because admin is also "Everyone". Thus, for me, I can't accomplish this task, to allow only admin see certain albums.

Please count this in for the next fix. Thanks a lot. Hope this helps you a little in user management design.

Alan

 
Shemo725

Joined: 2008-04-18
Posts: 424
Posted: Fri, 2010-07-09 07:59

are the album views and album owners not supposed to show up by default anymore?

http://gallery.andrewshemo.com/index.php/

 
bharat
bharat's picture

Joined: 2002-05-21
Posts: 7993
Posted: Fri, 2010-07-09 15:18

@ferguson731: which logout link did you click? Please verify that it says "RC 2" in the version info in the bottom left corner of your install. The logout link you have should a query param in there like "csrf=123456abcd" -- does it have that?

@zzpy20: we need to doc permissions better. If you want a set of users to see something special, create a group for them, give that group view permissions and take away view permissions for all other groups.

@Shemo725: The wind theme is clean and simple so we don't show that info. If you add the "metadata" block to the sidebar, you'll see the album owner in the sidebar when you click into the album/photo. But we don't show the view count anywhere currently. Please file a ticket for that and we'll consider it for 3.0.

---
Problems? Check gallery3/var/logs
bugs/feature req's | upgrade to the latest code | use git

 
ferguson731

Joined: 2010-07-09
Posts: 8
Posted: Fri, 2010-07-09 17:03

@bharat: Thanks for the prompt response. Yes my page footer says "Powered by Gallery 3.0 RC2 (Santa Fe)". And yes the logout link (top right corner or main gallery page) has a csrf= component in it.

I will try to paste it into this message and see if your forum spam filter lets it through:

http://my.host/gallery/index.php/logout?csrf=24dd3b3960fcf4c02184e76a3518b632&continue_url=http%3A%2F%2Fmy.host%2Fgallery%2Findex.php%2F

This works fine on my localhost installation (Mac OSX 10.6.3, Apache 2.2.14, PHP 5.3.1). I notice that the "Server API" in the output of phpinfo here says "Apache 2.0 Handler" whereas on hostgator it says "CGI/FastCGI" (as well as being PHP 5.2.13).

George

 
Shemo725

Joined: 2008-04-18
Posts: 424
Posted: Fri, 2010-07-09 20:27

bharat,

the views and album owner always used to show up..at least in RC1 it did.

for example, here's a gallery that's still on RC1:
http://www.pazrt.com/gallery/

I'm using the rwinfo module from rwatcher, but even with that disabled, the views and album owner shows up when you hover over the albums!

 
nivekiam
nivekiam's picture

Joined: 2002-12-10
Posts: 16504
Posted: Fri, 2010-07-09 21:38
Quote:
the views and album owner shows up when you hover over the albums!

That's the behavior that I'm seeing in the link you provided and that's the intended behavior of the Wind theme. Hover over the thumbnail and you get that info, otherwise, it's not displayed.
____________________________________________
Like Gallery? Like the support? Donate now!!! See G2 live here

 
Shemo725

Joined: 2008-04-18
Posts: 424
Posted: Sat, 2010-07-10 04:15
nivekiam wrote:
Quote:
the views and album owner shows up when you hover over the albums!

That's the behavior that I'm seeing in the link you provided and that's the intended behavior of the Wind theme. Hover over the thumbnail and you get that info, otherwise, it's not displayed.
____________________________________________
Like Gallery? Like the support? Donate now!!! See G2 live here

correct, on the above provided link that's still on RC1.

not on my gallery that's on RC2.

http://gallery.andrewshemo.com/

it doesn't work in Chrome or Firefox.

 
nivekiam
nivekiam's picture

Joined: 2002-12-10
Posts: 16504
Posted: Sat, 2010-07-10 04:43

Do you have the Info module activated?
____________________________________________
Like Gallery? Like the support? Donate now!!! See G2 live here

 
Shemo725

Joined: 2008-04-18
Posts: 424
Posted: Sat, 2010-07-10 05:18
nivekiam wrote:
Do you have the Info module activated?
____________________________________________
Like Gallery? Like the support? Donate now!!! See G2 live here

d'oh..not I didn't!

it's working now..thanks.

 
bharat
bharat's picture

Joined: 2002-05-21
Posts: 7993
Posted: Sat, 2010-07-10 05:40

@ferguson731: that's odd! Can you send me login details on your G3 so that I can try to reproduce the issue remotely?
---
Problems? Check gallery3/var/logs
bugs/feature req's | upgrade to the latest code | use git

 
nivekiam
nivekiam's picture

Joined: 2002-12-10
Posts: 16504
Posted: Sat, 2010-07-10 06:07
Shemo725 wrote:
d'oh..not I didn't!

it's working now..thanks.

Glad that worked!
____________________________________________
Like Gallery? Like the support? Donate now!!! See G2 live here

 
eportuguesas

Joined: 2010-06-06
Posts: 16
Posted: Sat, 2010-07-10 16:38

Gallery software is good but lacks good themes for download.

They should also invest more in it.

Is my opinion. :)
_________________________________________________
[G3 RC2] [url]www.estradasportuguesas.net[/url]

 
emanuelis

Joined: 2010-06-29
Posts: 5
Posted: Sat, 2010-07-10 16:42

Hi,
I have migrated my old Gallery2 (2.2.6) to a new Gallery3 RC2. This is what I have noticed about it after using it for one day.

Good:
1. It is very KISS.
2. Faster than Gallery2.
3. Looks nicer than Gallery2 (default skins).
4. Much simpler to rotate a photo.
5. Very easy to translate to local language.
6. Very simple and very fast installation.
7. Better comments than in Gallery2.

Bad:
1. When renaming an album (Internet Address) I get an error.
2. "Organize album" dialog sometimes is blank. But after closing it and trying again - everything works fine.
3. If I create an album and move some photos to it, no default album cover is selected.
4. Album cover can be only a photo (or album) from one level deeper. I liked the "highlight" in Gallery2.
5. After importing photos from Gallery2 there is something wrong with ascending/descending options. After importing photos this field is blank and walking through album photos "Next" and "Previous" works incorrectly. I had to manually select "descending" in every album to fix that.
6. "Add tag to photo" is a nice feature. But that auto complete is a bit annoying. I type faster than it autocompletes and sometimes when I press "," (comma) it chooses some suggested tag instead of what I typed. I think it is ok to autocomplete on "enter" or even on "space", but please remove "," from autocomplete function.
7. Didn't find how to set or modify the captured date. It is a very useful feature in Gallery2 especially when a photo lacks exif data.
8. "Edit captions" of a multiple photos was very useful feature in Gallery2.
9. Didn't find how to remove "index.php" from url.

Neutral:
1. When importing from Gallery2 both galleries must belong to the same user.

--
http://www.emanuelis.eu

 
nivekiam
nivekiam's picture

Joined: 2002-12-10
Posts: 16504
Posted: Sat, 2010-07-10 17:15

emanuelis:

bad 1) Known problem and there is a ticket for it

bad 2) We'd need more information about your environment and setup. Please start a new thread if this continues to be a problem

bad 3) Thanks, same thing for me. I've created a ticket:
https://sourceforge.net/apps/trac/gallery/ticket/1196

bad 4) That, like G2, requires a 3rd party module. It's not been written yet for G3, someone in the community will either have to write it or wait.

bad 5) Please start a new thread for that topic

bad 6) Please start a new thread for that or file an enhancement ticket:
https://sourceforge.net/apps/trac/gallery/newticket

bad 7) I believe there is a 3rd party module for that (see the Edit Creation module here)
http://codex.gallery2.org/Category:Gallery_3:Modules

bad 8) That functionality may be added to the organize module in the future, please search for and if you don't find it file an enhancement ticket here:
https://sourceforge.net/apps/trac/gallery/newticket

bad 9) You can do that by editing the .htaccess that ships with G3. There are detailed instructions in that file about what to uncomment and change.

Neutral: There's nothing that we can possibly do about that. The G2 import module requires that G2 be installed on the same server as G3 have access to the embed.php through the file system for G2.

Like Gallery? Like the support? Donate now!!! See G2 live here

 
Lord Beowulf
Lord Beowulf's picture

Joined: 2010-03-31
Posts: 56
Posted: Sat, 2010-07-10 17:56

Hi guys,

One question. I note that the theme format appears to have changed with RC2 (moved a lot of themeroller into the theme to allow editing other graphics, etc.). The result is that my previous theme I'd been working on now has some holes in it. I expect to be able to resolve that easily enough, but is there any documentation of the changes to the theme and the best way to edit it, etc.?

Thanks,

Beo

 
floridave
floridave's picture

Joined: 2003-12-22
Posts: 27300
Posted: Sat, 2010-07-10 18:52

We moved the lib/themeroller files into the individual themes in RC2. Most 3rd party themes have done this already. So we did this for future theme developers to make it easy for them.

copy lib/themeroller into your themes/xxx/css directory.

See http://github.com/gallery/gallery3/commit/3b05db2685d92ca538d7993c960b06ea32f3a8df

Dave

_____________________________________________
Blog & G2 || floridave - Gallery Team

 
fotoron

Joined: 2010-04-25
Posts: 32
Posted: Sun, 2010-07-11 10:22

Logging out from the admin backend logout menu-option results in a "Dang... Page not found!" error, it is redirecting me to "http://mywebsite/login", which does not exist.

Logging out from via the frontend logout option does the right thing, redirecting me to "http://mywebsite/"

Anyone else seeing this?

 
surgeon

Joined: 2005-01-18
Posts: 80
Posted: Sun, 2010-07-11 11:13

Navigation in G3RC2.

When I watch the picture in the album, which is on the 7th page in example, after clicking on the icon navigation "up", I return to the first page of the album. And I would like to return back to 7th page, there where I was before clicking on the picture.

(GreyDragon, GWTorganise. I assume that the same acts in WindTheme)

 
bharat
bharat's picture

Joined: 2002-05-21
Posts: 7993
Posted: Sun, 2010-07-11 14:37

@fotoron: good catch. I filed this ticket: https://sourceforge.net/apps/trac/gallery/ticket/1201

@surgeon: I think this is a bug in the GreyDragon theme -- I can't reproduce this in the wind theme.
---
Problems? Check gallery3/var/logs
bugs/feature req's | upgrade to the latest code | use git

 
kellym
kellym's picture

Joined: 2003-04-15
Posts: 29
Posted: Sun, 2010-07-11 20:45

Great stuff, G3 is looking very impressive.

Just one problem, I can't get the slideshow to work on anything but one browser, IE7 on a PC. It does not work on any Mac browsers (Safari, Firefox, or Chrome) and it doesn't work on Firefox for the PC either.

UPDATE: sorry it was a computer problem, I tried it on another Mac and works fine.

--
Kelly's smooth running, free flowing Gallery 1: [url]www.redbeet.com/pictures[/url]

 
blaufotograph

Joined: 2007-07-30
Posts: 53
Posted: Sun, 2010-07-11 20:41

Hi @All,

i would like to ask for the php safe mode support. It is supported within the gallery? And what have i to do for getting it running?

Thank you very much

 
nivekiam
nivekiam's picture

Joined: 2002-12-10
Posts: 16504
Posted: Sun, 2010-07-11 20:48
blaufotograph wrote:
Hi @All,

i would like to ask for the php safe mode support. It is supported within the gallery? And what have i to do for getting it running?

Thank you very much

Safe mode isn't supported and never will be. Safe mode is bad security, period and if your host is using it, find a different host as they don't have a clue what they are doing. It's also been depreciated in current versions of PHP (5.3) and will be removed from PHP 6.0.

____________________________________________
Like Gallery? Like the support? Donate now!!! See G2 live here

 
bharat
bharat's picture

Joined: 2002-05-21
Posts: 7993
Posted: Mon, 2010-07-12 02:38

@ferguson731: Thanks for sharing the details of your install. I can reproduce the problem on your site. I get a 403 forbidden when the logout link contains a valid url in the continue_url parameter, but not otherwise. This 403 isn't generated by the Gallery 3 code -- it's happening at a lower level in your server. Some experimentation on your system indicates that Hostgator is running some anti-phishing code that's looking for the string "http:" in the url and if it finds that parameter it rejects the request. While I applaud their desire to keep phishing requests down, their breaking our app (which because we use a cross-site request forgery token, is phishing proof here). Can you file a ticket with them and see what they can do?
---
Problems? Check gallery3/var/logs
bugs/feature req's | upgrade to the latest code | use git

 
Lord Beowulf
Lord Beowulf's picture

Joined: 2010-03-31
Posts: 56
Posted: Mon, 2010-07-12 04:19

bharat et. al.:

I'm still seeing some inconsistencies/issues with folder permissions, groups, etc. I'm trying to give a group access to create and edit their own folders. I was trying to determine how to allow a group to create folders without giving them the ability to edit other users folders. Unfortunately there aren't user level permissions in the current architecture, so it currently looks like the only option would be for me to give each user a separate group and create a root folder for each one that only they then have full permissions to edit. That's not terribly practical long term, so I'll have to look into a more effective solution.

At any rate, in the process, I'd enabled full permissions for the group in the root folder but disabled them in my sub folder and ended up with a directory structure that disabled all folder editing options BUT delete!!! Not exactly what I'm looking for, to say the least. If I turn of Edit in the root then delete's gone for the user group in the protected folder. Note that playing with these permissions is also again causing weirdness with some gallery thumbs showing as broken links even though the user should be able to see them.

Also, on deleting a folder, I end up with a 404 error rather than getting moved up the tree.

Hopefully you can reproduce these issues and come up with fixes. And if there's any way to add user level protection (i.e. other than an admin, only the user that creates a folder or file can edit/delete it) that would be great.

Thanks,

Beo

 
floridave
floridave's picture

Joined: 2003-12-22
Posts: 27300
Posted: Mon, 2010-07-12 04:24
Quote:
Also, on deleting a folder, I end up with a 404 error rather than getting moved up the tree.

This has been fixed. http://sourceforge.net/apps/trac/gallery/ticket/1185 http://github.com/gallery/gallery3/commit/7ca201b11819ca5bfbcbe76f43bfe7d706c0f27f

Dave
_____________________________________________
Blog & G2 || floridave - Gallery Team

 
edbeeny

Joined: 2009-11-26
Posts: 14
Posted: Mon, 2010-07-12 19:46

Can Gallery 3 resize images when uploading them? At present I'm having to use third party software to shrink the size of the photo before I upload.
If not can this be added?

Thanks

 
nivekiam
nivekiam's picture

Joined: 2002-12-10
Posts: 16504
Posted: Mon, 2010-07-12 19:56

Every version of Gallery can resize photos when uploading. That's how they all work. But if you're thinking of something more along the lines of Gallery Remote that with the help of some 3rd party tools can resize on the local machine before uploading, then no, that isn't yet available for G3.

Personally, I use irfanview to batch resize my photos to save upload time and server disk space and it's fast and easy.
____________________________________________
Like Gallery? Like the support? Donate now!!! See G2 live here

 
ferguson731

Joined: 2010-07-09
Posts: 8
Posted: Mon, 2010-07-12 20:37

I contacted hostgator support to inquire. They replied promptly, saying "I've whitelisted these rules for you" and pointing me to the following post regarding mod_security rules:
http://forums.hostgator.com/re-deployed-mod-security-rule-t74963.html?p=222665

Their action fixed the problem for me. Don't know about in general.

George

 
edbeeny

Joined: 2009-11-26
Posts: 14
Posted: Mon, 2010-07-12 21:56

ok thanks, I know g2 used to but after trying g3 the images seem not to have changed size!
Is the resize setup by default?
Thanks