Gallery 3.0 Alpha-3 Feedback

bharat
bharat's picture

Joined: 2002-05-21
Posts: 7993
Posted: Tue, 2009-03-24 21:02
This topic is for feedback on the third technology preview of Gallery 3.0 (alpha 3). 3.0-Alpha-3 release announcement
 
kellym
kellym's picture

Joined: 2003-04-15
Posts: 29
Posted: Tue, 2009-03-24 21:49

Guys (and gals), I've used Gallery since 2002. I've even donated to the project. I still use Gallery 1.5 and it works great (www.redbeet.com/pictures). I like the direction that 3.0 is headed. Simpler is better.

I have one very simple request: could you make it easy to add my own PHP header and footer? In the Gallery 1.5.10 and prior, editing the html_wrap/wrapper.header and wrapper.footer was simple and easy. I could never figure out how to do this with Gallery 2. I spent hours trying and gave up. So I still use Gallery 1.5 today. Adding my own header/footer should be very simple and easy, not requiring me to edit the Gallery code, CSS, or Smarty template kung-fu... just use wrapper.header and wrapper.footer again and I will love you forever. Or at least until Gallery 4.0. :)

Thanks for all your hard work.

Kelly Martin

 
bharat
bharat's picture

Joined: 2002-05-21
Posts: 7993
Posted: Tue, 2009-03-24 22:05
@kellym: Guess what, we added that feature in Alpha 3! Follow the menus: Admin -> Presentation -> Theme Details and there you can add whatever you want to the header and footer. Let us know what you think.
 
dasunst3r

Joined: 2009-03-25
Posts: 4
Posted: Wed, 2009-03-25 02:55

I just installed it real quick on my web server. I know some people who would love this because the UI feels a lot more intuitive. The uploader needs some significant improvement:

  • The uploader should not lock up the browser while it's uploading.
  • The uploader needs to be case-insensitive on the extensions. I have many pictures with .JPG, and the uploader refuses to recognize those until I rename them to .jpg.
  • Gallery3 should read the EXIF information for the orientation sensor information and rotate the picture, if needed.

Finally, Does anybody know if Digibug will be included in the final version of Gallery3?

 
floridave
floridave's picture

Joined: 2003-12-22
Posts: 27300
Posted: Wed, 2009-03-25 03:07
Quote:
The uploader needs to be case-insensitive on the extensions. I have many pictures with .JPG, and the uploader refuses to recognize those until I rename them to .jpg.

I don't see that behavior. Can you post some more info;
browser? version? flash version?

Dave
_____________________________________________
Blog & G2 || floridave - Gallery Team

 
yeahy

Joined: 2008-11-07
Posts: 69
Posted: Wed, 2009-03-25 05:26

Cool, will install a3 tonight.

 
neutcomp
neutcomp's picture

Joined: 2004-07-28
Posts: 28
Posted: Wed, 2009-03-25 07:49

Hello,

I have two questions:

1) Random image block is this also posible to implement this (and modify) on my own website (php and/or .net envouriment)?
2) I have one base installation and multiple gallery's. Is this feature also in gallery 3?

Thanks and hope to hear from you soon!

Bjorn

 
hebhansen
hebhansen's picture

Joined: 2009-02-10
Posts: 573
Posted: Wed, 2009-03-25 09:12

Is there a roadmap from Alpha2 to Alpha3. Do you just dump it on top or is it a clean install?

I have to say - amazing what you have accomplished - it truly is.

Looks very very promising with the multilanguage feature. maybe when settling in certain people should be assigned to certify quality of translations... But lets see how it turns out.

all the best
HB

 
hebhansen
hebhansen's picture

Joined: 2009-02-10
Posts: 573
Posted: Wed, 2009-03-25 09:49

Still don't see image when using the SWF-uploader in alpha 3. Had the same for Alpha 2

In fact I get log'ed out of gallery and need to log in again

all the best
HB

 
cj_nza

Joined: 2004-05-26
Posts: 10
Posted: Wed, 2009-03-25 11:50

I encounter a situation where a rotate photo command affects the thumbnail adjacent to the one I am trying to change.

Unable to reliably reproduce, originally thought that it impacted by scroll mouse, but attempts to reproduce reliably escapes me. (Note the behavior has been observed several times, it simply cannot be reproduced reliably.)

 
Dhaos

Joined: 2008-01-10
Posts: 10
Posted: Wed, 2009-03-25 12:47

@floridave i have the same problem as dasunst3r

The flash uploader only accepts files with lowercase extensions and there is no option for *.* (all filetypes).

Running Ubuntu 8.10 (intrepid) x64 and Shockwave Flash 10.0 r22 (latest release in repositories)
The same problem appears across latest firefox stable (3.0.7) and Minefield releases.

And interestingly gallery3 is completely broken in konqueror.

 
hebhansen
hebhansen's picture

Joined: 2009-02-10
Posts: 573
Posted: Wed, 2009-03-25 12:51

If sticking to the plan of a strict core in Gallery. People will add their individual modules as is the case for Drupal. In Drupal, core modules are placed in www.mysite.com/modules
Same level as index.php etc.

Add-on modules are placed elsewhere in
www.mysite.com/sites/all/modules
When starting up with Drupal this folder is empty. Within a day or two it is packed

this for clean separation but found by Drupal as if it was in the prime module folder. In other words two folders are checked for modules.

Sorting this out now before mass production of periferal modules might be a good idea.

Going the "ad-on-module-way" I think Gallery core should have a function for checking for upgrades. In Drupal this is done by Cron-jobs. Automated, flush, cash-clean,delete unused short-URLs, checking for updates at drupal.org etc.

This requires that Gallery.org collects upgrades of modules for G3 G4 etc. respectively and provides upgrade info to all of out galleries when requested.

In other words developers are required to upload modules, define gallery version & module vesrion etc. A feature where users can grade modules could be a great help for others as an indication wether the module is worth while.

Looks like this for Drupal:
http://drupalmodules.com/top-rated

all the best
HB

 
yeahy

Joined: 2008-11-07
Posts: 69
Posted: Wed, 2009-03-25 13:32

How you guys install a3 base on a2. Just found the lazy way didn't work. :) Uploaded and overrided all files to the server, droped all tables. When I pointed web browser at gallery3/installer/, I got a install finished message and refuse to re-install. :( Trying to figure out how to proceed...

 
floridave
floridave's picture

Joined: 2003-12-22
Posts: 27300
Posted: Wed, 2009-03-25 13:53
neutcomp wrote:
2) I have one base installation and multiple gallery's. Is this feature also in gallery 3?

No. G3 is small enough to install over again and makes the code less complex, smaller, more efficient, faster....

Dave

_____________________________________________
Blog & G2 || floridave - Gallery Team

 
floridave
floridave's picture

Joined: 2003-12-22
Posts: 27300
Posted: Wed, 2009-03-25 13:59
cj_nza wrote:
I encounter a situation where a rotate photo command affects the thumbnail adjacent to the one I am trying to change.

Unable to reliably reproduce

I too have had this issue and have been unsuccessful in reproducing reliably.

Dave

_____________________________________________
Blog & G2 || floridave - Gallery Team

 
bharat
bharat's picture

Joined: 2002-05-21
Posts: 7993
Posted: Wed, 2009-03-25 16:18

ok, comment roundup!

@dasunst3r: The uploader shouldn't lock up the browser, that must be a browser bug. What browser are you using? I created a ticket for the case insensitivity issue here: https://apps.sourceforge.net/trac/gallery/ticket/183

@neutcomp: we don't yet have any external API code for the image block, but we'll provide some. We also don't yet have support for "multisite" (one codebase, multiple galleries) but that's on our roadmap.

@hebhansen: there's no upgrade path from A2 to A3. Delete the A2 code, drop the database and do a fresh install. We aim to provide an upgrade path from B1 to future versions. As for site-only modules, we'll do that when we get around to implementing multisite support for G3. One thing at a time.. we don't yet have a working app for a *single* site :-)

@yeahy: there's no upgrade path from A2 to A3. Delete the A2 code, drop the database and do a fresh install.

@cj_nza: what browser are you using?

All: if you're getting logged out, edit core/config/session.php and change the 'regenerate' value from 100 to 0 and see if that helps.

 
dasunst3r

Joined: 2009-03-25
Posts: 4
Posted: Wed, 2009-03-25 18:08

I am currently using Ubuntu 9.04 Alpha 6 amd64, Firefox 3.0.7, and Flash 10.0 r22 64-bit.

 
jezmck
jezmck's picture

Joined: 2009-02-27
Posts: 27
Posted: Wed, 2009-03-25 20:46

Definately don't try copying a3 over a2, there are a number of problems, e.g. renamed module (local upload -> server upload).

Edit 1:

Instructions/feedback feedback:
The server add works great, but it should be made more obvious that adding files from a subfolder will add them to a new sub-album.
The file-tree also needs some more feedback to show that it is retrieving a directory listing, and should be sorted with folders at the top.

Edit 2:
I think that there's a problem uploading images, deleting and reuploading same images.
i.e. they now don't exist on the server.

Edit 3:

cj_nza wrote:
I encounter a situation where a rotate photo command affects the thumbnail adjacent to the one I am trying to change...

Just had the same but for deleting! NB this deleted a duplicate image before it (which was created by the Server Add module).

#4: Randomly logged out, anyone else see this?

#5: Viewing a deleted tag shows the Kohana error/trace - will there be a standard more friendly error page eventually?

Please note that I might be reporting several bugs, but am loving G3!

 
jezmck
jezmck's picture

Joined: 2009-02-27
Posts: 27
Posted: Wed, 2009-03-25 19:35

sorry for double post but I think it warrants its own.

I would love to eliminate index.php from the URLs, will this be possible?

 
yeahy

Joined: 2008-11-07
Posts: 69
Posted: Wed, 2009-03-25 20:53

Thx all, works smooth now.

# Added translation server and localization client (alpha 3)
Good, smooth. Easy setting and easy sharing.

# Reimplemented the Flash uploader using SWFUpload (alpha 3)
Uploader can tell if there's any error when dealing with multi-byte file names. alpha2 can't tell.

# Add photos directly from the web server (improved in alpha 3)
Will try tomorrow.

Support below tickets raised by florin_andrei:
- Tooltips for buttons: https://apps.sourceforge.net/trac/gallery/ticket/186
- Make the "Add Photo" button more prominent: https://apps.sourceforge.net/trac/gallery/ticket/188

 
yeahy

Joined: 2008-11-07
Posts: 69
Posted: Wed, 2009-03-25 21:02

Tag module, is it possible to treat space character as a splitter ?

 
plasticgoat

Joined: 2007-01-31
Posts: 17
Posted: Wed, 2009-03-25 23:59

Hi,

I have finally install imagemagick and done a fresh install with this alpha3 today: Add photos from server works fine now :)

BUT, still some issues so far:

- I have been disconnected several times, from admin account, without any message, while browsing a gallery and rotating photos. (same issue as jezmck)

- I have noticed the same behavior as cj_nza, but only once:
I encounter a situation where a rotate photo command affects the thumbnail adjacent to the one I am trying to change.

I agree with dasunst3r, Gallery3 should definitely read the EXIF information to rotate automatically the picture, if needed.

Well it's going better and better, good job !! Thx

Gallery is installed on Debian Lenny and I my browser is latest Firefox on Mac OSx

 
floridave
floridave's picture

Joined: 2003-12-22
Posts: 27300
Posted: Thu, 2009-03-26 00:14
plasticgoat wrote:
- I have been disconnected several times, from admin account, without any message, while browsing a gallery and rotating photos. (same issue as jezmck)

bharat wrote:
All: if you're getting logged out, edit core/config/session.php and change the 'regenerate' value from 100 to 0 and see if that helps.

Dave

_____________________________________________
Blog & G2 || floridave - Gallery Team

 
bharat
bharat's picture

Joined: 2002-05-21
Posts: 7993
Posted: Thu, 2009-03-26 02:14

@dasunst3r: Hm. The latest Firefox, the latest Flash on the latest Ubuntu? I'm guessing that there's some instability there that needs to get worked out. If you can reproduce this with a more common config, I'm happy to spend some time investigating.

@jezmck: we will remove index.php from your urls by the final release, stay tuned. we will (eventually) have more user friendly error pages. the random logout issue is known and will be fixed. I *believe* that the delete/reupload bug was fixed right after A3 got released, can you try a nightly snapshot and see if it's still around?

@yeahy: yes, we can do that but I'm not convinced that's what people want. what do other tagging sites (flickr, etc) do?

@plasticgoat: regarding the issue about accidentally resizing the wrong photo, were you flipping back and forth between thumbnails? Perhaps our ajax code misfired and pulled the context menu for the wrong item. Automatically rotating images based on EXIF data is on our roadmap, but is not a high priority. might make it into 3.0, might not.

 
hebhansen
hebhansen's picture

Joined: 2009-02-10
Posts: 573
Posted: Thu, 2009-03-26 07:15

Not a bug - just FYI. Maybe add this to the FAQ or install:
--------------
Upload and filemanagement using Flash (SWF)

Sympton:
The Flash uploader opens, I can pic files to upload, the status bar updates and completes. When I press done, the images are not there.

Diagnose:
Problems using flash uploads is often mistakenly related to the Apache module "mod_security". However, this will not fix the problem. To solve the flash upload issue in your Gallery, you need to deactivate the php.ini variable called: "suhosin.session.cryptua".

Salvation:
Locate the variable in your php.ini setup and set it to "off". Failing to do so will obstruct the Flash-uploader in your Gallery 3 site. It seems to upload, but it doesn't do so and your files are not to be found on your site either.

Remember to repeat this for multisite installations and subdomains.

Your upload problem should be fixed by now!

all the best
HB

 
cj_nza

Joined: 2004-05-26
Posts: 10
Posted: Thu, 2009-03-26 08:17

@bharat - Similar behavior in Firefox 3.0.7 and Opera 9.64 both running on Windows XP Pro SP3 and Firefox 3.0.7 on Ubuntu 8.10

 
yeahy

Joined: 2008-11-07
Posts: 69
Posted: Thu, 2009-03-26 08:59
bharat wrote:
@yeahy: yes, we can do that but I'm not convinced that's what people want. what do other tagging sites (flickr, etc) do?

:) Flickr's tag tips: Separate each tag with a space: cameraphone urban moblog (will generate 3 tags). Or to join 2 words together in one tag, use double quotes: "daily commute" (will generate 1 tag).

 
yeahy

Joined: 2008-11-07
Posts: 69
Posted: Thu, 2009-03-26 10:01

Two suggestions for better user exp:

1. Right now the EXIF info is shown in a popup window. Flickr style is to refresh the whole page to jump to the EXIF page. Picasa style and gallery2.3 are same: using ajax. Picasa is faster, and it can remember the setting. e.g. if you turn on exif info, when you browse to next photos, the exif info is still on, really considerable. if you don't want to see it, you can turn it off. :)

2. Using ajax to add/edit title and description. Please check the attached imgs. When the mouse move over the title area, the background of input form became yellow and echo a tip : click to edit. Then the user can click the area and add/modify the title or description without leaving the page. :)

 
jezmck
jezmck's picture

Joined: 2009-02-27
Posts: 27
Posted: Thu, 2009-03-26 13:37
bharat wrote:
...regarding the issue about accidentally resizing the wrong photo, were you flipping back and forth between thumbnails?
...
what do other tagging sites (flickr, etc) do?
...
Automatically rotating images based on EXIF data is on our roadmap, but is not a high priority. might make it into 3.0, might not.

1: I believe I was, because I couldn't decide which to delete.
2: the space as a separator gets my vote - that's what is done in bbPress forums, and at delicious.com
3: Please reconsider - I get really irritated when people don't rotate images, and if it can just do it for them then everyone wins :)

 
jzapata

Joined: 2008-09-06
Posts: 16
Posted: Fri, 2009-03-27 14:56

Is more of a request than a comment.

In Gallery 2, if you close the browser without first login out, and then somebody comes after you and opens the browser and goes to gallery2, they will get your instance if the time limit has not expired. It will be nice if gallery3 will detect the browser closing and terminate the active instance.

 
bharat
bharat's picture

Joined: 2002-05-21
Posts: 7993
Posted: Fri, 2009-03-27 15:49

@hebhansen: good catch with cryptua, forgot about that. Does that work if you set that it in the .htaccess file? If so I'll add that to the default distro.

@cj_nza: I can't reproduce the lockup :-( Can anybody else?

@yeahy, jezmck: I've filed https://apps.sourceforge.net/trac/gallery/ticket/193 for the tagging issue. thanks!

@jezmck: exif rotation.. it's all about priorities. which would you rather have, exif image rotation or security, import from gallery 2 or bulk edit? We have to prioritize. We'll get to it.

@jzapata: edit core/config/session.php and set expiration to 0 to get the behavior you want. We will probably eventually make this configurable in the db.

Whew! Moving to a new house today/tomorrow so I might be slow to respond for a while...

 
cj_nza

Joined: 2004-05-26
Posts: 10
Posted: Sun, 2009-03-29 08:46

Changed permissions on top level and got this:

An error was detected which prevented the loading of this page. If this problem persists, please contact the website administrator.

>core/libraries/Theme_View.php [32]:

Missing argument 2 for Theme_View_Core::__construct(), called in /var/www/ ... /core/controllers/albums.php on line 30 and defined

 
cj_nza

Joined: 2004-05-26
Posts: 10
Posted: Sun, 2009-03-29 08:55

@bharat, if you are referring to the DB lockup, please ignore at this point. Typed my windows MySQL credentials during setup/install. Re-installed gallery, pointing to Linux MySQL DB and so far so good re DB lock-up.

 
boost

Joined: 2007-01-04
Posts: 13
Posted: Sun, 2009-03-29 13:32

Gallery 3 looks nice. I just wish it would work for Apache on Windows.

I get one of these for each image added with "server add":
PHP Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 11264 bytes) in D:\\Web\\wwwroot\\gallery3\\kohana\\libraries\\drivers\\Image\\GD.php on line 76, referer: http://mydomain/gallery3/index.php/

I know you not support Windows systems, but thought I would mention it anyways.

Using Windows Server 2003
Apache 2.2.6 with PHP 5.2.9-1

 
jureb

Joined: 2008-05-30
Posts: 12
Posted: Mon, 2009-03-30 09:53

I've tested Gallery 3.0 Alpha-3. It looks useful and clear looking.
I miss two features from Gallery 2 that I widely use.

1. size limiting - actually image downsamling of a picture that is being uploaded.

2. lightbox slide show
Yes, you have included Cooliris slide show. But the problem at Cooliris is that you cannot set a picture size - so the small pictures are stretched all over the screen and they don't look nice. I would just like to have them in an original pixels size (as it is in the gallery). Lightbox slide show gives me that option and that's why I prefer it. It also gives me the possibility to download pictures of an album in cache (or in advance) - which is useful because I have slow connection to the server.

 
floridave
floridave's picture

Joined: 2003-12-22
Posts: 27300
Posted: Mon, 2009-03-30 13:29
Quote:
Yes, you have included Cooliris slide show. But the problem at Cooliris is that you cannot set a picture size - so the small pictures are stretched all over the screen and they don't look nice. I would just like to have them in an original pixels size (as it is in the gallery).

There has been some fixes:
http://www.flashyourweb.com/filemgmt/index.php?id=21

Dave

_____________________________________________
Blog & G2 || floridave - Gallery Team

 
jureb

Joined: 2008-05-30
Posts: 12
Posted: Mon, 2009-03-30 17:33

If I've understood you right, this option of setting the maximum image pixel size will be included in Gallery 3 cooliris slide show, because in aplha I haven't seen it yet?

 
floridave
floridave's picture

Joined: 2003-12-22
Posts: 27300
Posted: Mon, 2009-03-30 18:24

I was just sending you a link for G2 only. I don't know of the cooliris plans for g3.

Dave
_____________________________________________
Blog & G2 || floridave - Gallery Team

 
m-d-d
m-d-d's picture

Joined: 2009-03-01
Posts: 28
Posted: Tue, 2009-03-31 02:27

Alpha 3 is a big improvement over Alpha 2. Connection through secure port (https://) works, can sort pictures, upload is a lite better. I like this release much more then previous one!

I just installed script. Will test it for couple of days.

Thank you, good job!

 
jureb

Joined: 2008-05-30
Posts: 12
Posted: Tue, 2009-03-31 10:05
floridave wrote:
I was just sending you a link for G2 only. I don't know of the cooliris plans for g3.

Well it is included already.

 
lokto7
lokto7's picture

Joined: 2009-02-03
Posts: 8
Posted: Tue, 2009-03-31 13:28
boost wrote:
Gallery 3 looks nice. I just wish it would work for Apache on Windows.

I get one of these for each image added with "server add":
PHP Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 11264 bytes) in D:\\Web\\wwwroot\\gallery3\\kohana\\libraries\\drivers\\Image\\GD.php on line 76, referer: http://mydomain/gallery3/index.php/

I know you not support Windows systems, but thought I would mention it anyways.

Using Windows Server 2003
Apache 2.2.6 with PHP 5.2.9-1

didn't test Gallery3 Alpha 3... hopefully they could make it happen on Windows...

 
Oldiesmann
Oldiesmann's picture

Joined: 2005-05-18
Posts: 151
Posted: Tue, 2009-03-31 17:40

Minor gripe with the rewritten URLs in Gallery 3...

I recently recompiled PHP on my server, changing it from an Apache module to CGI/FastCGI. I enabled the "cgi.fix_path_info" setting as this is normally needed to properly support rewritten URLs in CGI mode.

However, Gallery3 is leaving "/index.php" in the rewritten URLs, which makes them look ugly. I like having rewritten URLs because it makes them easier to remember and more meaningful to users, but I'd rather not have to hack anything to make it leave out "/index.php" when running PHP as CGI.
---------------------
The Oldiesmann
SMF Project Manager
SMF+G2 Integration Project - RC1 now available!

 
bharat
bharat's picture

Joined: 2002-05-21
Posts: 7993
Posted: Tue, 2009-03-31 20:36

@cj_nza: thanks! I just fixed the Theme_View bug in r20517 in svn.

@boost: FAQ: PHP memory_limit - Why do I get the error Allowed memory size of Xxx bytes exhausted?

@Oldiesmann: We have not yet properly implemented short urls. The final result won't have index.php in them.

 
boost

Joined: 2007-01-04
Posts: 13
Posted: Tue, 2009-03-31 21:00

@bharat:
As you can see in the error message I have 32M in memory limit which should be enough when it only tries to allocate 11264 bytes ?
However I could try to make more memory available, but it works fine in Gallery2 with 32M.

Edit: Well.. Actually in Gallery2 I use ImageMagick instead of GD, but Imagemagick doesnt work in Gallery3 on Windows, because there is being used unix commands to find the 'convert' file. I tried to hardcode it to 'C:\Program Files\Imagemagick', but then I get errors that 'C:\Program' is not recognized as an internal or external command.

And I guess Imagemagick is not limited by the PHP memory limit.

 
bharat
bharat's picture

Joined: 2002-05-21
Posts: 7993
Posted: Tue, 2009-03-31 20:56

@boost: 32M is not enough. It's trying to allocate 11264 bytes, but it's already allocated ~32M so there aren't that many bytes left. GD does image manipulation in PHP's memory space and it uncompresses the image into RAM so a 3MB compressed JPG can turn into 24-28M in memory, and then any subsequent operations on it (resize, rotate, etc) eat up your remaining memory. Choices: allocate more memory, stop using GD or upload smaller images.

 
boost

Joined: 2007-01-04
Posts: 13
Posted: Tue, 2009-03-31 22:19

The easiest for me (right now) is to allocate more memory, until I figure out how to trick Gallery3 into using Imagemagick.

Update:
By moving ImageMagick to C:/ImageMagick, it now works.

 
alexandreracine

Joined: 2005-06-16
Posts: 39
Posted: Tue, 2009-03-31 23:31

@bahrat : Some content might be for you, like number 6 down here.

Alright, let's check this alpha 3 now :)

First of all, it's getting better and better :)

Since it is going to the path of usuability for the user (or user friendly), I'll try to go in that direction.

1- Minor bug : When adding a first comment, the "Be the first to comment!" stays until you refresh the page.

2- Oups bug : The dashboard is pretty nice, but the "General Settings" and "Presentation" links in the first block do not work.

3- Usability : Activating the local import and adding pictures. If I check the square left of the folder /tmp/tmp, in this instance, the "import" button is still grey out until I clic on the "+" left of the folder name.

4- Usability : Where is the sorting option inside albums? Can't find it. (Witch is not good for usuability if it's there ;)

5- Request : In the dashboard, in the gallery stats, would it be nice to have the server load or not? Or... adding a module that would provide such a block would be possible to write?

6- Bug : While adding pictures from the local server, the "Rebuild Images" task stalled and had to be cancelled. Running it manually (Run) does not continue the operation. Deleting all albums and doing it again gives the same error. In apache log, I could find plenty of those : "[Tue Mar 31 19:20:56 2009] [error] [client 192.168.230.201] File does not exist: /var/www/gogo/gallery-3.0-alpha-3/var/thumbs/fdas/IMG_2651.JPG, referer: http://machine/gogo/gallery-3.0-alpha-3/index.php/fdas" When I first tested this feature, it was working great, but it seems like there is something wrong here on the long term. The folder was fdas empty when I did that test.

Alexandre Racine
http://www.salsamontreal.com - Évènement, photos et beaucoup plus!

 
m-d-d
m-d-d's picture

Joined: 2009-03-01
Posts: 28
Posted: Thu, 2009-04-02 02:31

I found a bug related to international character in Albums Name.

I created an album with Name and Title 'Nasze Zdjęcia' (our photos in Polish). The album was created, but it was unaccessible due to error in Name encoding.

The output error message:

[img]http://img17.imageshack.us/img17/7475/errorw.gif[/img]

I think the Name field need to be more carefully sanitized or transcoded when this kind of strange character is presented. I would suggest WordPress attempt where for example any character like 'ę' in post link will be replaced be straight 'e' automatically.

 
m-d-d
m-d-d's picture

Joined: 2009-03-01
Posts: 28
Posted: Thu, 2009-04-02 03:09

And other questions and comments.

1. What is a Queue limit? I was going to upload 183 photos at once and what I got was an error message that I was over the max limit of pictures in queue.

2. flv movies are still displayed with improper height . The hight of player window is this same as height of original movie. That means the displayed movie's height is smaller by player toolbar height. For example I have a movie 320 by 240px. In G3 the movie in the player has 320 by 240 minus player toolbar height.

<a id="gMovieId-66" href="https://ServerName/galeria3/var/albums/lala.flv" style="display: block; width: 320px; height: 240px;">

The problem relay in wrongly defined hight. It should be height of the movie plus height of player's controls toolbar!

3. Deleted album still exist on server. I removed one album from gallery, but when I checked on server side the directory was still there and all pictures were inside.

 
kellym
kellym's picture

Joined: 2003-04-15
Posts: 29
Posted: Thu, 2009-04-02 03:58

I've been trying out G3 Alpha 3 but can't even get the thumbnails to work. When I go to Admin | Settings | Graphics menu, I get a runtime error (screenshot attached, below). I'm running GD 2.0.35_1 and ImageMagick-nox11-6.4.9.8 on FreeBSD 6.4-p3. Sorry if I'm a complete idiot and have missed something obvious, I'll have a look through the configuration and the code if I have time, and see if I can figure out why.

Despite this problem, I would like to say THANK-YOU for making it easy to add a header/footer in the themes. As I mentioned early in this thread, I'm a longtime G1 user. Also, I am really impressed with the interface and overall direction of Gallery 3.

kelly

[img]http://www.redbeet.com/images/G3-A3-screenshot1.jpg[/img]

 
kellym
kellym's picture

Joined: 2003-04-15
Posts: 29
Posted: Thu, 2009-04-02 04:25

I got the thumbnails to work by just updating the config in the vars table of the database. Gallery 3 was assuming my GD toolkit was located in /usr/bin when in fact mine was in /usr/local/bin. So I simply ran the SQL query UPDATE vars SET value = "/usr/local/bin" WHERE id = 8; and it's working. Still get the error above when going to the Admin | Settings | Graphics menu, though.

One thing I noticed when viewing the full size image: the close X icon does appear at the top right corner of the image, and when I close it the image goes away but Gallery stays stuck in the darkened background and seems to think the image is still there, so I can't go anywhere. I suspect this is a browser/javascript issue. I'm running Safari 3.2.1 on Mac OS X.

kelly